Serveurs & Infrastructure

Solution – Putty Fatal Error Couldn’t agree a client-to-server cipher

Par Tutos-Info , le 16 juin 2022 - 2 minutes de lecture
5/5 - (1 vote)

L'outil Putty est un outil génial pour vous connecter à des équipements sur le protocole SSH et Telnet. Il est gratuit et utilisé par la plupart des techniciens systèmes et réseaux. Récemment j'ai rencontré un soucis  pour me connecter sur une machine , une erreur "Couldn't agree a client to server cipher". Voici la solution pour ne plus avoir de problèmes.

Putty et l'erreur Couldn't agree a client-to-server cipher

En voulant me connecter en SSH sur un équipement (un switch) j'ai eu ce beau message d'erreur :

Message fatal error putty
Le message Could'nt Agree a client to server cipher.

En telnet pas de soucis puisqu'il n'y a pas de certificats SSL pour assurer la sécurité du flux, le problème est donc uniquement localisé pour un usage du protocole SSH.

Le message parle également d'algorithme de chiffrement comme l'AES128

La solution est en réalité toute simple il suffit de mettre à jour Putty ! Pour mon problème j'ai du installé la version 0.77 directement depuis le site officiel.

Il faut privilégier la version la plus récente qui prend en charge les nouvelles normes de sécurité.

Une fois installée vous pouvez vous connecter aux machines.

Comment connaître sa version de putty ?

Vous pouvez connaître la version de Putty en cliquant sur le bouton "About".

putty about

Puis la version de Putty s'affiche :

afficher la version de putty
La version 0.76 de Putty.

Tutos-Info

Fondateur de Tutos-Informatique, je suis Administrateur Systèmes et Réseaux. Je propose des tutoriels suite à mes interventions clients.

Commentaires

Laisser un commentaire

Votre commentaire sera révisé par les administrateurs si besoin.