Serveurs & Infrastructure

Serva – Booter des Iso et DVD d’installation Windows sur le LAN

Par Tutos-Info, le 7 juin 2016, mis à jour le 13 avril 2017 — serva, serveur pxe, windows — 6 minutes de lecture

Si vous avez besoin de faire des déploiements de masse alors SERVA vous sera probablement utile ! L'application permet de créer en 2 - 3 clics un serveur PXE sur n'importe quel PC WINDOWS, ainsi vous pourrez déclencher les installations Windows simultanément sur plusieurs postes depuis un boot réseau sur ce serveur. Mais ce n'est pas tout vous pouvez également booter des ISO ( type Acronis, Hiren'Boot ....)

Maj 12/04/17

  • Amélioration du tutoriel sur le partage des dossiers
  • Ajout du lien pour le tuto d'une mise en place complète

Serva licence et tarifs

Version gratuite

Serva est disponible gratuitement , cependant vous n'aurez pas toutes les fonctionnalités ainsi que des restrictions :

– Lorsque vous le lancer vous devez attendre 7 secondes pour accéder à l'application
– Vous pourrez utiliser un maximum de 7 images PXE

– L'interface n'est pas personnalisable
– Serva est utilisable uniquement pendant 50 min. ( vous devez relancer Serva une fois les 50 minutes atteintes )

- Le BOOT UEFI n'est pas disponible

- Vous pouvez faire du démarrage PXE sur seulement 2 postes simultanément.

serva temps attente version gratuite

Version professionnelle

tarifs serva supporter version

serva licence

Pour de l'utilisation Professionnelle cherchez pas prenez la licence vous la rentabiliserez bien assez vite vu le temps gagné !

Préparation du serveur Serva

Téléchargement de l'application

La première étape est de télécharger l'application ( 64 bits si vous l'installez sur un Windows 64bits )

Il n'y a pas d'installation c'est un utilitaire "portable"

Création d'un dossier

Sur votre disque créer un dossier qui accueillera les différents ISO , fichiers de Conf , vous pouvez l'appeler StockagePXE par exemple

Configuration de Serva

Cliquez sur l'Exe de l'application , en bas  à droite à coté de l'heure sur l'icône Serva faire un clique droit puis SETTINGS

options serva

On va ensuite passer la configuration , on va indiquer les paramètres TFTP ,  DHCP suivez les captures d'écran

serva configuration tftp

serva option dhcp

Si vous avez déjà un DHCP ( serveur , votre box ... ) alors cochez la case ProxyDHCP et BINL

Si vous n'avez pas de services DHCP alors cochez la case DHCP SERVER et BINL , pensez à cocher le "Bind DHCP to this address"

Attention pour que les réglages soient appliqués il faut fermer Serva puis le relancer

Partage des dossiers

Dans votre dossier StockagePxe vous devriez avoir les dossiers suivants :

serva dossier pxe

En rouge ce sont les dossiers à partager.

  • NWA_PXE :  ce dossier contiendra les ISO , les systèmes Linux
  • WIA_WDS : ce dossier contiendra les ISO décompressés Windows 7 à 10 mais aussi Windows PE
  • WIA_RIS : ce dossier contiendra les ISO décompressés Windows XP

Pour partager les dossiers voici la procédure :

Clique droit > Propriétés > Onglet Partage > Partage Avancé >

serva partage des dossiers

Pensez bien à nommer le partage avec le _SHARE pour assurer le fonctionnement de Serva.

  • NWA_PXE_SHARE
  • WIA_RIS_SHARE
  • WIA_WDS_SHARE

serva partage dossier

Dans Autorisations cocher les 3 cases autoriser pour Tout le monde

serva partage dossier

Maintenant allez dans l'onglet "Sécurité" puis faire "Modifier" , soit vous autorisez Tout le monde , soit un utilisateur , soit tous les utilisateurs authentifiés , ils doivent avoir tous les droits ( le contrôle total est facultatif )

serva option sécurité

Répétez l'étape pour les 2 autres dossiers si vous devez les utiliser.

Cas des Postes ou architecture sans domaine

Si vos PC ne sont pas dans un domaine il faut supprimer le partage par mot de passe dans la configuration avancée du réseau. Cela évitera des dysfonctionnements.

Allez dans le panneau de configuration puis dans Centre Réseau et partages

Windows accès au centre réseau et partages

Windows accès centre réseau et partage 2e partie

En haut à gauche dans les partages avancés

Windows accès aux partages avancés

Puis chercher l'option Partage Protégé par Mot de passe , choisir la case Désactiver le partage protégé par mot de passe

Ajout des OS, ISO , utilitaires

Windows : Il faut créer un dossier dans le dossier WIA_WDS ( exemple Windows7 ) dans ce dossier vous allez copier le contenu du fichier ISO.

Linux , Utilitaires ( Acronis ... )Il faut créer un dossier dans le dossier NWA_PXE( exemple Acronis ) dans ce dossier vous allez copier l' ISO ( ce cas fonctionne pour Acronis ) , puis nous allons créer un fichier de configuration nommé "ServaAsset.inf" voici le contenu à copier coller pour Acronis

;-Serva v3.0 Non-Windows Asset Information File
;-Boot/Install:
; ACRONIS
;-Tested on:
; ACRONIS
; ACRONIS
;-Require:
; -
;-Notes:
; Client's memory must be > 2.2 * ISO size
[PXESERVA_MENU_ENTRY] asset = Acronis
platform = x86
kernel_bios = memdisk
append_bios = iso initrd=\NWA_PXE\$HEAD_DIR$\acronis.iso raw

Pour les autres systèmes merci de vous référer à cette documentation  . Vous trouverez les informations à mettre dans le fichier "ServaAsset".

Pensez à fermer & relancer Serva quand vous avez finit vos manipulations , ainsi de les prendre en compte.

Accélérer le démarrage d'Acronis

Vous allez voir le boot d'acronis peut prendre du temps car la technologie TFTP n'est pas faites pour le transfert de fichiers volumineux ( ici près de 500 MO l'iso ).

Pour mon cas ayant pris la version pro de SERVA je fais mon boot ACRONIS via WINDOWS PE. Vous avez avec votre licence ACRONIS l'outil pour créer votre média.

Utilisation

Les PC qui vont utiliser SERVA doivent être connectés via câble réseau au réseau local , démarrez les puis faire F12 pour démarrer sur le LAN :

serva démarrage

Voici le menu qu'on obtient quand on boot sur le LAN

Attention si vous bootez sur Windows vous devrez rentrer un login et mot de passe pour accéder au dossier de partage, pensez à indiquer le nom du PC ( ou le domaine ) avant le login !

Serva boot windows

ICI mon domaine est MASTER donc j'utilise MASTER\Administrateur puis le mot de passe du compte Administrateur. Un mauvais partage, des droits mal paramétrés provoqueront des erreurs.

Problèmes & dépannage

Si votre PC n'a pas de driver LAN il faut les télécharger puis les mettre dans le dossier  Windows que vous avez mit dans WIA_WDS :

le dossier se trouve ici :

$OEM$\$Boot$\$1\$WinPEDriver$\NIC\

N'hésitez pas à poser vos questions dans les commentaires de cet article.

J'ai également mis en ligne un tutoriel très complet en complément de celui-ci. J'explique pas à pas comment j'ai mis en place ce système dans ma société. Création d'une image "master", déploiement en masse si ça vous intéresse suivez ce lien.

Enfin voici une vidéo explicative faîtes par Mikaël de Tech2tech

 

Tutos-Info

Commentaires

Le 15 décembre 2020 à 17 h 32 min, tektek a dit :


Salut Tutos-Info, en réponse à tes questions du 13/12 au soir

Hello, est-ce que tu as un pc en mode BIOS et non UEFI si oui est-ce que ça fonctionne ?
Réponse : mes 2 pcs en dur sont anciens et tous les 2 en BIOS et les 2 ne fonctionnent pas, exit PXE en PXE53

Tu peux éventuellement créer une VM en mode "bios" et non UEFI , le but étant d'identifier si le problème vient des pc en uefi.
Réponse : Oui une VM ubuntu en mode BIOS sans succès non plus...exit PXE en PXE51

On est d'accord que les partages des fichiers sont OK au niveau du nom et des autorisations ?
Réponse : Oui

Merci pour ton aide, cordialement,


Votre réponse sera révisée par les administrateurs si besoin.

Le 13 décembre 2020 à 18 h 53 min, Tektek a dit :


Bonjour, j'ai beau suivre le tuto à la lettre serva ne fonctionne pas. J'ai mon DHCP sur free et sur serva TFTP server coché et proxyDHCP ainsi que BINL cochés. Mes pcs clients boot après recherche dhcp en pxe erreur 53. En virtualbox en pxe erreur 51. J'ai déjà vérifié, mes partages sont accessibles depuis d'autres PC.
Voici les 3 warm dans serva concernant des serva assets non trouvés :
[12/13 18:24:44.957] BINL Inf: Preparation/Maintenance procedures "Start" **
[12/13 18:24:45.020] BINL Inf: Created OK, D:\TFTP\BM\PXESERVA\BIOS\pxeserva.cfg\menu.def
[12/13 18:24:45.037] BINL Warn: Serva assets not found when creating D:\TFTP\BM\PXESERVA\EFI32\pxeserva.cfg\menu.def
[12/13 18:24:45.047] BINL Inf: Created OK, D:\TFTP\BM\PXESERVA\EFI32\pxeserva.cfg\menu.def
[12/13 18:24:45.106] BINL Warn: Serva assets not found when creating D:\TFTP\BM\PXESERVA\EFI64\pxeserva.cfg\menu.def
[12/13 18:24:45.111] BINL Inf: Created OK, D:\TFTP\BM\PXESERVA\EFI64\pxeserva.cfg\menu.def
[12/13 18:24:45.923] BINL Inf: Preparation/Maintenance procedures "End" **
Est-ce que quelqu'un peut me dire si mes problèmes viennent de là ? ou me donner une piste ? car là je botte en touche. Merci


Votre réponse sera révisée par les administrateurs si besoin.

Le 13 décembre 2020 à 22 h 21 min, Tutos-Info a dit :


Hello, est-ce que tu as un pc en mode BIOS et non UEFI si oui est-ce que ça fonctionne ?
Tu peux éventuellement créer une VM en mode "bios" et non UEFI , le but étant d'identifier si le problème vient des pc en uefi.
On est d'accord que les partages des fichiers sont OK au niveau du nom et des autorisations ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 16 décembre 2020 à 22 h 44 min, tektek a dit :


Salut Tutos-Info, en réponse à tes questions du 13/12 au soir

Hello, est-ce que tu as un pc en mode BIOS et non UEFI si oui est-ce que ça fonctionne ?
Réponse : mes 2 pcs en dur sont anciens et tous les 2 en BIOS et les 2 ne fonctionnent pas, exit PXE en PXE53

Tu peux éventuellement créer une VM en mode "bios" et non UEFI , le but étant d'identifier si le problème vient des pc en uefi.
Réponse : Oui une VM ubuntu en mode BIOS sans succès non plus...exit PXE en PXE51

On est d'accord que les partages des fichiers sont OK au niveau du nom et des autorisations ?
Réponse : Oui

Merci pour ton aide, cordialement,

PS: pour info mes 2 pcs sont sur le même réseau mais en CPL


Votre réponse sera révisée par les administrateurs si besoin.

Le 20 décembre 2020 à 20 h 25 min, Tutos-Info a dit :


Bonsoir, désolé pour le retard ,
SERVA est t'il exclus du pare-feu Windows ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 19 octobre 2020 à 13 h 31 min, Stephane a dit :


Bonjour,

Je rencontre un soucis avec mon serva qui est sur son propre reseau et qd je lance mon client le DHCP ok mais j'ai un soucis avec le tftp avec un message d'erreur 10054 avec le fichier pxeserva.0 qui a été fermé par l'hote distant. Mon firewall est desactivé, mes partages sont bon. Merci a vous de votre aide.

Cdt,


Votre réponse sera révisée par les administrateurs si besoin.

Le 21 septembre 2020 à 13 h 36 min, Halsberghe Nicolas a dit :


Bonjour, J'ai exactement le même problème que fabien petit. Quelqu'un a t'il une solution car je ne sais pas trop d'ou cela peut venir. :/ Merci d'avance.


Votre réponse sera révisée par les administrateurs si besoin.

Le 7 avril 2020 à 14 h 14 min, Yannick a dit :


Bonjour, merci pour ce travail ayant amené à la création de ce tutorial.
Je l'ai suivi et tout fonctionne parfaitement.
J'ai une question sur le déploiement avec SERVA.
Est-il possible d'augmenter le débit du transfert car en TFTP cela prends un temps fou (1 Mo/s)?
Je sais qu'il y a un onglet HTTP et FTP dans SERVA mais je ne trouve pas comment rerouter le transfert via l'un ou l'autres.
Merci de votre aide


Votre réponse sera révisée par les administrateurs si besoin.

Le 11 avril 2020 à 21 h 56 min, Tutos-Info a dit :


Bonjour , pour moi le PXE utilise uniquement le protocole TFTP. il est plus lent que http / ftp.
Par contre ton réseau est en quel vitesse ? Gigabits ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 5 novembre 2019 à 23 h 10 min, ITMEB a dit :


Bonjour a tous,
Je rencontre un problème avec mon serveur pxe serva3.2 sur un systeme windows serveur 2016 std, impossible de faire booter mes machines cliente sur le pxe, mes clients elles ont bien une adresse IP mais le tftp est pas accessible.

GATEWAEY IP:192.168.1.1
TFTP.
PWE-T01:
PXE-E3B : TFTP Error File not found
PXE-E3B : Exiting intel pxe rom

Vous avez une idée ?

mercii


Votre réponse sera révisée par les administrateurs si besoin.

Le 11 novembre 2019 à 17 h 01 min, Tutos-Info a dit :


Bonjour, votre parfe-feu est désactivé ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 16 septembre 2019 à 11 h 49 min, joska a dit :


tout est bien expliquer sauf qu'il faut bien expliquer comment au préalable faire le réseau Ethernet avec des câbles a paires torsades..on peut avoir un commutateur qui relie ces ordinateurs a installer et celui du serveur d'installation.


Votre réponse sera révisée par les administrateurs si besoin.

Le 7 septembre 2019 à 11 h 04 min, Bertrand a dit :


J'ai laissé un commentaire le 3 juin et tu n'as pas répondu puisque ça fait 3 mois sans aucun réponse
tu es occupé?


Votre réponse sera révisée par les administrateurs si besoin.

Le 3 juin 2019 à 0 h 12 min, Bertrand a dit :


Bonsoir,

je voulais savoir si il y a une licence pour serva pro ou non

par exemple

un pc qui a serva pro mais le disque dur tombe en panne alors il faut racheter le serva pro ou réutiliser la licence de serva pro sur le nouveau disque dur

car la question que je me pose comment ça se passe pour la licence de serva pro ?

2ème question : le serveur pxe est allumé donc ça consomme beaucoup de bande passante pour l'installation d'un système exploitation ou non ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 9 septembre 2019 à 13 h 27 min, Tutos-Info a dit :


Bonjour, désolé pour le retard.
Donc voici les réponses :)
Tu peux réinstaller le logiciel avec la licence même si ton disque dur tombe en Panne. Conserve la source précieusement.
Pour la 2e question : ça consomme de la bande passante quand lance les installation. (uniquement bande passante locale c'est pourquoi il faut un reseau local en giga bit).


Votre réponse sera révisée par les administrateurs si besoin.

Le 25 mai 2019 à 12 h 01 min, bentouati a dit :


bonjour ,
concernant les pc freedos , comment on pourra booter avec


Votre réponse sera révisée par les administrateurs si besoin.

Le 27 mai 2019 à 12 h 36 min, Tutos-Info a dit :


je n'ai pas testé cette version.


Votre réponse sera révisée par les administrateurs si besoin.

Le 16 avril 2019 à 13 h 39 min, Koloina a dit :


Bonjour,
J'avais bien suivi le tuto, étape par étape, pourtant j'avais encore eu le message suivant: "[09/01 17:59:38.161] BINL Err: WIA_RIS_SHARE wrong setup; 127.0.0.1:445 SMB share doesn’t point to G:\SERVA"
Est-ce que quelqu'un peut aider?
Merci d'avance.


Votre réponse sera révisée par les administrateurs si besoin.

Le 16 avril 2019 à 21 h 41 min, Tutos-Info a dit :


bonjour,
il semblerait que les partages ne soient pas corrects.
Le g:\ est un disque dur ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 27 mars 2019 à 15 h 49 min, Tom a dit :


Bonjour j’ai suivi le tuto a la lettre et a la fin Serva me met ceci au démarrage:
[11/06 00:57:52.626] BINL Inf: Preparation/Maintenance procedures « Start » **
[11/06 00:57:52.689] BINL Inf: WIA_WDS_SHARE OK; 127.0.0.1:445
[11/06 00:57:52.689] BINL Inf: Preparation/Maintenance procedures « End » **


Votre réponse sera révisée par les administrateurs si besoin.

Le 31 mars 2019 à 22 h 17 min, Tutos-Info a dit :


le message ne me parraît pas anormal arrivez-vous à démarrer les isos depuis le lan ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 17 mars 2019 à 7 h 12 min, Julien a dit :


Bonjour,

Ayant marre de perdre des clé USB je me suis dit que j'allait le faire via mon réseau privé.

Tout fonctionne mais au moment de l’identification pour accéder au dossier là ou est mes fichiers cela ne fonctionne pas.
Ou se trouve c'est identifiants car j'ai essayer se de mon ordi est cela ne fonctionne pas .

Pouvez vous m'aidez ?

Merci.


Votre réponse sera révisée par les administrateurs si besoin.

Le 21 mars 2019 à 15 h 11 min, Tutos-Info a dit :


Bonjour, les identifiants sont ceux d'un compte utilisateur de votre pc qui héberge les données. Il faut bien sûr que ce compte ai les droits d'accès sur le partage.


Votre réponse sera révisée par les administrateurs si besoin.

Le 12 novembre 2018 à 13 h 17 min, Electrodydy a dit :


Bonjour, j'ai trouver le problème venais de mon Switch qui bizarrement remplacé par un bête hub laisser passer le pxe je vais devoir changer mon Switch mais je vois pas pourquoi il bloque le pxe :/
En attendant je vous remercie pour avoir essayé de m'aider :)


Votre réponse sera révisée par les administrateurs si besoin.

Le 6 novembre 2018 à 17 h 30 min, Electrodydy a dit :


aprés un test sur un autre PC voici ce que j'obtient dans les logs:

[11/06 17:22:13.965] BINL Inf: Preparation/Maintenance procedures "Start" **
[11/06 17:22:14.215] BINL Inf: Expandd OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\pxeboot.n12
[11/06 17:22:14.465] BINL Inf: Expandd OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\bootmgr.exe
[11/06 17:22:14.559] BINL Inf: Copied OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\boot\boot.sdi
[11/06 17:22:14.812] BINL Inf: Expandd OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\bootmgfw.efi
[11/06 17:22:14.827] BINL Inf: Copied OK C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\MICROSOFT\EFI64\bootmgfw.efi 6.1.7601.17514
[11/06 17:22:14.827] BINL Inf: Copied OK C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\MICROSOFT\EFI64\bootmgfw.efi.org
[11/06 17:22:14.827] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\ServaBINL.dat
[11/06 17:22:15.531] BINL Inf: Injected OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\boot\ServaBoot.wim Added [2]\Windows\System32\ServaPENet.exe
[11/06 17:22:15.562] BINL Inf: Injected OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\boot\ServaBoot.wim Added [2]\Windows\System32\Winpeshl.ini
[11/06 17:22:15.578] BINL Inf: Injected OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\boot\ServaBoot.wim Added [2]\Serva.txt
[11/06 17:22:15.593] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\WIA_WDS\Windows_7\_SERVA_\boot\bcd
[11/06 17:22:15.593] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\BIOS\pxeserva.cfg\menu.def.bak
[11/06 17:22:15.593] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\BIOS\pxeserva.cfg\menu.def
[11/06 17:22:15.593] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\BIOS\pxeserva.cfg\menu.def
[11/06 17:22:15.593] BINL Warn: Serva assets not found when creating C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\EFI32\pxeserva.cfg\menu.def
[11/06 17:22:15.609] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\EFI32\pxeserva.cfg\menu.def
[11/06 17:22:15.625] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\EFI64\pxeserva.cfg\menu.def.bak
[11/06 17:22:15.625] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\EFI64\pxeserva.cfg\menu.def
[11/06 17:22:15.625] BINL Inf: Created OK, C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\EFI64\pxeserva.cfg\menu.def
[11/06 17:22:15.715] BINL Inf: WIA_WDS_SHARE OK; 127.0.0.1:445
[11/06 17:22:15.717] BINL Inf: Preparation/Maintenance procedures "End" **

enfait la seule erreur apparemment et ici:

[11/06 17:22:15.593] BINL Warn: Serva assets not found when creating C:\Users\Electrodydy\Desktop\Serva_Community_64_v3.0.0\Deploy\BM\PXESERVA\EFI32\pxeserva.cfg\menu.def


Votre réponse sera révisée par les administrateurs si besoin.

Le 12 novembre 2018 à 13 h 11 min, Tutos-Info a dit :


il créer bien le menu , tu n'as pas de droits particuliers ?
ton deuxième poste c'est une machine virtuelle ? un pc physique ? sur le même réseau ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 6 novembre 2018 à 17 h 18 min, Electrodydy a dit :


oui il y a bien un fichier menu.def, voici son contenu:
############################################################################
# Serva Community v3.0.0 multi-OS PXE Boot/Install Menu definition (BIOS)
# by Patrick Masotta © 2010-2016
############################################################################

NOESCAPE 1
PROMPT 0

F1 pxeserva.cfg/F1

menu color title 1;37;44 #FFFFFFFF *
menu color border 37;44 #80FFFFFF #00000000 none
menu color sel * #FFFFFFFF #76A1D0FF *
menu color hotsel 1;7;37;40 #FFFFFFFF #76A1D0FF *
menu color tabmsg 37;40 #FFFFFFFF #00000000 *
menu color help 37;40 #FFDDDD00 #00000000 none

menu margin 4
menu width 78
menu rows 15

menu helpmsgrow 22
menu helpmsgendrow 24
menu tabmsgrow 21

menu title Serva Community v3.0.0 multi-OS PXE Boot/Install Menu (BIOS)
menu notabmsg Select an option and press ENTER to boot/install, or F1 for Help

il y a également un fichier nommé F1 dans ce dossier


Votre réponse sera révisée par les administrateurs si besoin.

Le 6 novembre 2018 à 1 h 18 min, Electrodydy a dit :


Bonjour j'ai suivi le tuto a la lettre et a la fin Serva me met ceci au démarrage:
[11/06 00:57:52.626] BINL Inf: Preparation/Maintenance procedures "Start" **
[11/06 00:57:52.689] BINL Inf: WIA_WDS_SHARE OK; 127.0.0.1:445
[11/06 00:57:52.689] BINL Inf: Preparation/Maintenance procedures "End" **
mais j'ai beau essayer de démarrer plusieurs PC sur le Réseau sa cherche et sa ne trouve rien ... je ne comprend pas ce que j'ai mal fais ...


Votre réponse sera révisée par les administrateurs si besoin.

Le 6 novembre 2018 à 13 h 23 min, Tutos-Info a dit :


bonjour, dans votre dossier SERVA avez vous bien un fichier menu.def ? il se trouve ici : DOSSIERSERVA\BM\PXESERVA\BIOS\pxeserva.cfg\
si oui qu'avez vous à l'intérieur ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 4 septembre 2017 à 20 h 49 min, dim_960 a dit :


Bonjour,
je viens de remarquer que cette erreur ne gêne en rien la connection PXE pour l'installation
merci pour tout


Votre réponse sera révisée par les administrateurs si besoin.

Le 1 septembre 2017 à 18 h 09 min, dim_960 a dit :


Bonjour,
j'ai cette erreur qui s'affiche,

[09/01 17:59:38.161] BINL Err: WIA_RIS_SHARE wrong setup; 127.0.0.1:445 SMB share doesn't point to C:\SERVA_PXE\

j'ai pourtant bien configurer comme dans le tuto, je précise que je passe par une
box SFR, pour installer un Windows XP en local.

Merci pour votre aide


Votre réponse sera révisée par les administrateurs si besoin.

Le 4 septembre 2017 à 12 h 37 min, Tutos-Info a dit :


bonjour, le partage de votre dossier est fait correctement ? le dossier serva_pxe se trouve sur votre c:\ ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 24 mai 2017 à 11 h 54 min, Fabien Petit a dit :


Bonjour,

bon c'est bon cela fonctionne, il y a eu un bug sous windows il avait gardé l'ancien chemin du répertoire de partage...

merci


Votre réponse sera révisée par les administrateurs si besoin.

Le 27 mai 2017 à 13 h 24 min, Tutos-Info a dit :


Super , merci pour ton retour ;)


Votre réponse sera révisée par les administrateurs si besoin.

Le 22 mai 2017 à 10 h 25 min, fabien Petit a dit :


Bonjour

Oui c'est fais un copié collé de l'ISO dans un un répertoire windows10
J'ai téléchargé l'ISO de W10 que j'ai monter et copier dans le répertoire.

J'arrive au menu serva avec le choix.
Apres j'obtiens cela TFTPD boot : 0.0.0.0 WIA_WDS\W10\_SERVA_\pxeboot.n12
et après could not find KERNEL image : vesamenu.c32

..

voila

fabien Petit


Votre réponse sera révisée par les administrateurs si besoin.

Le 23 mai 2017 à 22 h 06 min, Tutos-Info a dit :


comment avez vous configuré le tftp et le dhcp ?
comme sur le screen suivant ?
pour tftp https://www.tutos-informatique.com/wp-content/uploads/2016/06/serva-tftp.jpg
pour dhcp : https://www.tutos-informatique.com/wp-content/uploads/2016/06/serva-dhcp.jpg


Votre réponse sera révisée par les administrateurs si besoin.

Le 19 mai 2017 à 16 h 36 min, fabien Petit a dit :


Bonjour

J'ai un problème j'obtiens le menu de boot de serva mais message d'erreur cold not find kernel image. vesamenu.c32

alors que j'ai bien copier l'ISO de W10 dans un repertoire..

Avez vous une idée ?

merci

fabien


Votre réponse sera révisée par les administrateurs si besoin.

Le 20 mai 2017 à 14 h 43 min, Tutos-Info a dit :


Bonjour, avez vous bien extrait le contenu de l'iso dans le dossier WDS ? avez vous également bien respecté le nom du partage ? WIA_WDS_SHARE


Votre réponse sera révisée par les administrateurs si besoin.

Le 6 mai 2017 à 15 h 28 min, Jean a dit :


Bonjour et merci pour ce tuto c'est exactement ce que je cherchais, par contre peux tu m'expliquer la configuration du DHCP de serva, car j'ai des difficultés a le mettre en place , faut il assigner une ip fixe sur le pc ou serva est installé ?


Votre réponse sera révisée par les administrateurs si besoin.

Le 7 mai 2017 à 22 h 07 min, Tutos-Info a dit :


Pas forcément mais c'est mieux. Tu n'auras aucun souci à utiliser Serva sur un pc configuré en DHCP ;)


Votre réponse sera révisée par les administrateurs si besoin.

Le 29 janvier 2017 à 21 h 22 min, Aldo Macionne a dit :


Merci pour ce tuto que je vais lire... mais sans zomer la page puisque ctrl+molette ne fonctionne pas ici


Votre réponse sera révisée par les administrateurs si besoin.

Le 4 juillet 2016 à 22 h 20 min, Pierre a dit :


Génial !!!


Votre réponse sera révisée par les administrateurs si besoin.

Laisser un commentaire

Votre commentaire sera révisé par les administrateurs si besoin.