Accueil - Guides Plesk - Plesk – Comment mettre à jour PHP 5.4 avec Ubuntu

Plesk – Comment mettre à jour PHP 5.4 avec Ubuntu

Hello,

Ce tutoriel vous explique pas à pas comment mettre à jour PHP en version 5.4 sur PLESK 11.5 et 12 avec le système Ubuntu 12.04 LTS

Se connecter en SSH

La première étape consiste à vous connecter sur votre serveur en SSH à l’aide de Putty

Commandes Spécifiques

On ajoute dans les dépôt le lien des mises à jour php en version STABLE

add-apt-repository ppa:ondrej/php5-oldstable

On met à jour notre liste de dépôt

apt-get update

On installe la dernière version de PHP

apt-get install php5

Votre version PHP passera en dernière version stable !

Effets de bords liés aux mises à jour

Attention lorsque vous basculez vers une autre version de PHP vous pouvez avoir des bugs sur vos sites. En effet si vous utilisez des solutions toutes prêtes ( style WordPress, Prestashop … ) assurez vous qu’elles sont compatibles avec la version de PHP que vous installez.

Il en est de même pour les modules que vous ajoutez ! Prenons l’exemple de IONCUBE , ce dernier ne se met pas à jour avec PHP , il faut donc télécharger la version correspondant à celle de PHP ( ici ioncube 5.4.so ).

Une fois téléchargé , il faut extraire le fichiers tar et  placer le fichier .so dans le dossier usr/lib

Ajoutez à la fin du fichier PHP.INI le lien vers ioncube : (  il se trouve ici /etc/php5/apache2/ )

zend_extension = /usr/lib/ioncube/ioncube_loader_lin_5.4.so

Redémarrez Apache :

/etc/init.d/httpd restart

Conclusion

Votre serveur est désormais en dernière version stable de PHP.  J’ai remarqué un petit bug d’affichage sur le panel PLESK , en effet ce dernier affiche 5.3 mais on est réellement en 5.4

Si vous souhaitez avoir la toute dernière version disponible ajouter le dépôt suivant : ( A vos risques et périls ! ) et revenez à l’étape 2 du tutoriel , pensez également à votre version ioncube.

add-apt-repository ppa:ondrej/php5

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

En continuant à utiliser le site, vous acceptez l’utilisation des cookies. Plus d’informations

Les paramètres des cookies sur ce site sont définis sur « accepter les cookies » pour vous offrir la meilleure expérience de navigation possible. Si vous continuez à utiliser ce site sans changer vos paramètres de cookies ou si vous cliquez sur "Accepter" ci-dessous, vous consentez à cela.

Fermer